安全研究

您现在的位置 > 首页 > 安全研究 > Unix/Linux系统漏洞

Linux Kernel "FUSE_NOTIFY_INVAL_ENTRY"消息本地拒绝服务漏洞

作者: 发布时间:09/09/11


发布日期:2011-09-08
更新日期:2011-09-09

受影响系统:

Linux kernel 2.6.x

描述:


BUGTRAQ  ID: 49527

Linux Kernel是Linux操作系统的内核。

Linux Kernel在检查FUSE_NOTIFY_INVAL_ENTRY消息长度时存在本地拒绝服务漏洞,本地攻击者可利用此漏洞时内核崩溃,拒绝服务合法用户。

FUSE_NOTIFY_INVAL_ENTRY没有检查写入的长度,消息处理可能会溢出,造成“kernel BUG at fs/fuse/dev.c:629!”。

<*来源:Petr Matousek
  
  链接:http://permalink.gmane.org/gmane.comp.security.oss.general/5831
        http://permalink.gmane.org/gmane.linux.kernel.commits.head/313266
        http://permalink.gmane.org/gmane.linux.kernel.stable/16698
*>

建议:


厂商补丁:

Linux
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.kernel.org/